Known Problems, Limitations, and Important Facts for Plesk 12.5

Upgrade Notes

  • In Plesk 12.5, the ability to add a prefix to the name of backup files was removed. If you used backup name prefix as the means of differentiating between backups from different servers stored in one location, we suggest that after upgrading to Plesk 12.5, you store them in different directories instead. You can configure a separate directory for storing backups on every server in Backup Manager > FTP Storage Settings > Directory for backup files storage.

  • The minimum Plesk version for an in-place upgrade is now 10.4.4.

  • Starting with Plesk 12.5, the Plesk UI has been re-designed. If desired, the old Plesk interface can be enabled in Extensions > Skins and Color Schemes > Revert to the Plesk 12.0 color scheme.

  • Starting with Plesk 12.5, Dovecot is now used as the default IMAP/POP3 server.

  • The “Database backup repository” feature is being phased out. The corresponding controls will be displayed in the Plesk interface only if you uploaded any database backups to the repository before upgrading to Plesk 12.5, and will disappear once all database backups have been removed from the repository.

Linux

  • Plesk now manages the ulimit setting and increases it automatically as needed. There is no longer any need to increase ulimit manually to prevent Plesk from malfunctioning once a certain number of domains is reached.

Known Issues and Limitations

  • Backups stored in the FTP repository are not displayed in the Backup Manager if Plesk is unable to establish connection to the FTP repository.

  • Websites cannot be restored from Plesk backups if they were renamed after the backup was made.

  • After switching from MSMTP to a different mail server, the Mail tab disappears for all existing subscriptions, removing the ability to enable or manage the mail service. The issue can only be resolved via manipulating the Plesk database.

  • Installing Plesk via an EZ template on a container with an operating system supporting Apache 2.4 results in the php-fpm component being missing. The component can be installed by running the Plesk Installer manually.

  • It is impossible to reassign an IP address from one network interface to another using the plesk bin ipmanage command.

  • On Plesk servers using the IceWarp Merak mail server, the “mailbox size limit” setting is applied on the subscription level, not on the level of individual mailboxes. As a workaround, make sure that you set the limit sufficiently high.

  • Even if remote database access is enabled for a database user in Plesk, remote access is impossible if the database server only listens on the localhost IP address.

  • Enabling the Plesk Firewall extension blocks passive FTP unless the ip_conntrack_ftp module is loaded or the necessary exceptions for the ports used by passive FTP are configured manually.

  • After removing a custom PHP handler in Plesk, you can re-assign all domains that used it to use a different handler quickly and conveniently using the plesk bin repair utility.

  • PHP shipped with Plesk now comes with support for opcode cache modules out of the box.

Linux

  • At the moment there is no way to switch PHP-FPM from the UNIX socket to TCP.

  • Before performing the operating system upgrade, make sure you have read about the possible issues you may encounter. If you are upgrading from Debian 6, read this. If you are upgrading from Debian 7, read this.

  • Websites using the Apache module PHP handler do not work on Plesk for Linux servers with Apache 2.4 installed due to the ‘event’ MPM being used in Apache 2.4.

  • Performing a dist-upgrade on a server with Plesk for Linux installed corrupts the chrooted shell configuration and makes it impossible to log in to the server using the chrooted shell. If you provide chrooted shell access to your customers, we do not advise you to perform the dist-upgrade.

  • The Plesk File Sharing feature does not work for domains using the PHP-FPM handler on servers with Apache 2.4 installed. As a workaround, you can switch to FastCGI.

Windows

  • Plesk uses the IIS Default Web Site for website preview.

  • If a subscription is created based on a service plan with the ‘SSL support’ option disabled, and then this option is enabled at a later date, HTTPS bindings in IIS are configured for the subscription’s primary domain only, but not for any add-on domains or subdomains. As a workaround, the affected add-on domains and subdomains can be reconfigured with the help of the repair.exe utility.

  • If Plesk is running inside a Hyper-V virtual machine, enabling the dynamic memory feature and disabling the pagefile inside the virtual machine results in intermittent applicationHost.config file corruption issues. To avoid such issues, allocate a set amount of RAM to virtual machine and turn on the pagefile inside the VM.

  • The OPCache module is disabled by default on Windows because of the PHP issue (https://bugs.php.net/bug.php?id=71024). This issue affects only the sites with different PHP versions running in the same IIS application pool. If this issue does not affect your site, you can enable the OPCache module (click PHP Settings and set On for the opchache.enable option).

Your Comments