Résoudre les problèmes d'installation des applications

Lorsqu'une application ne peut être installée sur le site Web d'un client pour une raison quelconque, le client reçoit un message d'erreur qui lui conseille de contacter son hébergeur (vous). Ce message d'erreur contient également une brève description de l'erreur censée vous aider à identifier la source du problème.

En général, le problème le plus fréquent lors de l'installation d'une application est lié à PHP qui ne correspond pas aux prérequis de l'app.

  • La version de PHP n'est pas prise en charge.
    Pour résoudre ce problème, installez la version requise de PHP. Pour plus d'informations, consultez l'article sur l'installation de PHP.
  • L'extension PHP requise est désactivée.
    Pour résoudre ce problème, activez l'extension requise.
    • Pour activer l'extension de manière globale pour une version particulière de PHP, allez sous Outils & Paramètres > Paramètres PHP et cliquez sur le nom d'une combinaison version PHP/type de gestionnaire avec la version de PHP voulue. Vous pouvez sélectionner l'extension voulue dans la liste ou aller sur l'onglet php.ini et ajouter la directive PHP correspondante au fichier php.ini valable pour l'ensemble du serveur.
    • Pour activer l'extension pour un domaine précis, ajoutez la directive PHP à la configuration PHP du domaine. Pour en savoir plus sur ce thème, consultez la section Paramètres PHP.

Après ajout de la directive, redémarrez le serveur Web. Pour plus d'informations, consultez l'article sur les services système.

 

Leave your feedback on this topic here

If you have questions or need support, please visit the Plesk forum or contact your hosting provider.
The comments below are for feedback on the documentation only. No timely answers or help will be provided.