Paramètres PHP

Plesk assure la prise en charge intégrale du langage de script PHP, ainsi que plusieurs versions et types de gestionnaires PHP, le tout, prêt à l'emploi. Cette section explique comment les clients Plesk peuvent gérer les paramètres PHP de leurs domaines et sous-domaines depuis le Panneau Client.

La gestion PHP au niveau du domaine se déroule en trois phases :

  • Choix de la version PHP
  • Choix du type de gestionnaire PHP
  • Configuration de paramètres PHP supplémentaires

Remarque : selon les paramètres de votre abonnement, vous ne pourrez gérer que certains, voire aucun des paramètres décrits ci-dessous. Si vous devez gérer des paramètres PHP non accessibles, contactez votre hébergeur.

Choix de la version PHP

Plesk prend en charge plusieurs versions PHP prêtes à l'emploi. Pour choisir la version PHP d'un domaine ou sous-domaine, allez dans Sites Web & Domaines > Paramètres PHP. Dans le menu, sélectionnez la version souhaitée de PHP.

Si la version voulue n'est pas dans le menu, contactez votre hébergeur.

Remarque : les différentes versions de PHP ne sont pas compatibles à 100 %. Un site Web avec PHP 5.3 risque de mal fonctionner si vous configurez PHP 5.4 pour le domaine. Si vous n'êtes pas sûr de la version de PHP à choisir, utilisez le paramètre par défaut ou la dernière version disponible. Si votre site Web ne s'affiche pas correctement, passez à une autre version de PHP.

Choix du type de gestionnaire

Plesk prend en charge différents gestionnaires PHP prêts à l'emploi. Pour choisir le type de gestionnaire PHP d'un domaine ou sous-domaine, allez dans Sites Web & Domaines > Paramètres PHP. Dans le menu, sélectionnez le type de gestionnaire PHP souhaité.

Si vous n'êtes pas sûr du type de gestionnaire PHP à choisir, vous pouvez consulter cette documentation.

Configuration de paramètres PHP supplémentaires

Outre la version et le type de gestionnaire PHP, vous pouvez configurer de nombreux autres paramètres PHP dans Sites Web & Domaines > Paramètres PHP. La plupart de ces paramètres sont liés à la sécurité et aux performances, mais certains jouent sur les opérations des sites Web. Cliquez sur l'icône située à côté d'une option pour en savoir plus.

Si votre domaine utilise l'une des gestionnaires PHP "Application PHP", vous pouvez configurer d'autres paramètres PHP-FPM. Ceux-ci peuvent être utilisés pour ajuster le comportement PHP afin d'optimiser les performances de votre site Web.

Les valeurs par défaut de ces paramètres doivent être optimisées pour la plupart des sites Web. Si vous modifiez ces paramètres, cela risque d'affecter les performances de votre site Web ou de l'empêcher de s'afficher correctement. Nous vous recommandons de conserver les valeurs par défaut pour tous les autres paramètres, sauf si vous êtes certain des modifications. Si votre site Web devient lent ou arrête de charger après modification des paramètres PHP, réinitialisez les paramètres PHP vers leur valeur par défaut.

Activation de l'accélération PHP

Si votre hébergeur vous y autorise, vous pouvez activer l'accélération PHP, également appelée "opcode cache module", pour votre site Web. Si votre site Web est écrit en PHP, vous pouvez doubler sa vitesse ou plus en activant le "opcode cache module". Pour activer l'accélération PHP, allez dans Sites Web & Domaines > Paramètres PHP et définissez la valeur de opcache.enable sur "on".

Affichage des paramètres PHP

Pour voir les paramètres PHP actuels du domaine, y compris ceux niveau serveur, cliquez sur Voir la page phpinfo().

Héritage de paramètres PHP

Les domaines appartenant à un abonnement héritent des paramètres PHP définis au niveau de l'abonnement. Les sous-domaines héritent des paramètres PHP définis au niveau de leur domaine parent. Si votre abonnement inclut les droits correspondants, vous pouvez modifier les paramètres PHP de chaque domaine et sous-domaine indépendamment.

 

Types de gestionnaires PHP

Plesk assure la prise en charge intégrale du langage de script PHP, ainsi que plusieurs versions et types de gestionnaires PHP, le tout, prêt à l'emploi. Cette section répertorie les types de gestionnaires PHP qui sont utilisés dans Plesk.

Type de gestionnaire Performances Utilisation mémoire Détails sur le gestionnaire

Module Apache

Élevées

Faible

Ce gestionnaire est disponible uniquement dans Plesk pour Linux. Il s'agit de l'option de sécurité la moins performante, car les scripts PHP sont exécutés au nom de l'utilisateur Apache. Autrement dit, tous les fichiers créés par les scripts PHP de tout abonné d'un pack ont le même propriétaire (apache) et le même jeu de droits. C'est pourquoi, il est possible qu'un utilisateur affecte les fichiers d'un autre utilisateur ou des fichiers système importants. Vous pouvez éviter certains problèmes de sécurité en activant l'option safe_mode PHP. Cela désactive un certain nombre de fonctions PHP qui présentent des risques de sécurité potentiels. Cela peut entraîner le dysfonctionnement de certaines applications Web. L'option safe_mode est considérée comme obsolète et est supprimée de PHP 5.4.

Extension ISAPI

Élevées

Faible

Ce gestionnaire est disponible uniquement dans Plesk pour Windows. L'extension ISAPI permet d'isoler le site dans le cas où un pool d'applications IIS dédié est activé pour les abonnements. L'isolation du site signifie que les sites des différents clients exécutent leurs scripts de manière indépendante. Par conséquent, une erreur dans un script n'affecte pas le fonctionnement des autres scripts. En outre, les scripts PHP s'exécutent au nom d'un utilisateur système associé à un compte d'hébergement. Le gestionnaire de l'extension ISAPI n'est plus pris en charge depuis PHP 5.3.

Application CGI

Faibles

Faible

Le gestionnaire CGI permet d'exécuter les scripts PHP au nom d'un utilisateur système associé à un compte d'hébergement. Sur Linux, ce comportement est possible uniquement si le module suEXEC du serveur Web Apache est activé (option par défaut). Dans les autres cas, tous les scripts PHP sont exécutés au nom de l'utilisateur apache. Par défaut, le gestionnaire CGI n'est pas disponible pour les clients Plesk.

Application FastCGI

Élevées

Élevée

Le gestionnaire FastCGI exécute les scripts PHP au nom d'un utilisateur système associé à un compte d'hébergement.

Application PHP-FPM

Élevées

Faible

Ce gestionnaire est disponible uniquement dans Plesk pour Linux. PHP-FPM est une version avancée de FastCGI, qui présente de nombreux avantages pour les applications Web à fort trafic.