Paramètres PHP

Choisissez l'un des gestionnaires PHP suivants via Paramètres d'hébergement > Type de gestionnaire PHP en tenant compte de l'utilisation des ressources et des aspects sécuritaires de chaque option :

PHP_settings

 

Performance

Utilisation de la mémoire

Sécurité

Module Apache (Linux uniquement)

Haut.

S'exécute comme une partie du serveur Web Apache.

Bas

Ce gestionnaire (également appelé mod_php) est l'option la moins sûre, car tous les scripts PHP sont exécutés au nom de l'utilisateur apache. Autrement dit, tous les fichiers créés par les scripts PHP de tout abonné d'un pack ont le même propriétaire (apache) et le même jeu de droits. Ainsi, certains utilisateurs ont théoriquement la possibilité d'affecter les fichiers d'autres utilisateurs ou certains fichiers système importants.

Remarque : vous pouvez éviter certains problèmes de sécurité en activant l'option safe_mode PHP. Cela désactive plusieurs fonctions PHP incluant un potentiel risque de sécurité. Notez que ce risque peut mener au dysfonctionnement de certaines applications Web. L'option safe_mode est obsolète et a été arrêtée depuis PHP 5.3.

Extension ISAPI (Windows uniquement, non prise en charge depuis PHP 5.3)

Haut.

S'exécute comme une partie du serveur Web IIS.

Bas

L'extension ISAPI peut offrir une isolation du site dans le cas où un pool d'applications IIS dédiées est activé pour les abonnements. L'isolement du site signifie que les sites des différents clients exécutent leurs scripts de manière indépendante. Par conséquent, une erreur dans un script n'affecte pas le fonctionnement des autres scripts. En outre, les scripts PHP s'exécutent au nom d'un utilisateur système associé à un compte d'hébergement.

Remarque : le gestionnaire de l'extension ISAPI n'est plus pris en charge depuis PHP 5.3.

Application CGI

Bas.
Crée un processus pour chaque requête et le ferme une fois la requête traitée.

Bas

Le gestionnaire CGI permet d'exécuter les scripts PHP au nom d'un utilisateur système associé à un compte d'hébergement. Sur Linux, ce comportement est possible uniquement si le module suEXEC du serveur Web Apache est activé (option par défaut). Dans les autres cas, tous les scripts PHP sont exécutés au nom de l'utilisateur apache.

Nous vous conseillons d'utiliser le gestionnaire de l'application CGI uniquement pour rétablissement.

Application FastCGI

Haut (proche du module Apache et d'une extension ISAPI).

Maintient les processus en cours d'exécution pour traiter les autres requêtes entrantes.

Haut

Le gestionnaire FastCGI exécute les scripts PHP au nom d'un utilisateur système associé à un compte d'hébergement.

Application PHP-FPM (Linux uniquement)

Haut

Bas

PHP-FPM est une version avancée de FastCGI, qui présente de nombreux avantages pour les applications Web à fort trafic.

Le gestionnaire PHP-FPM est disponible uniquement s'il a été installé par l'hébergeur et si l'option Gérer PHP avec Nginx est activée dans les paramètres du site Web (onglet Sites Web & Domaines > sélectionnez un domaine > Serveur Web > Paramètres).

Remarque : basculer le PHP du module Apache vers l'application FastCGI risque de corrompre le fonctionnement des scripts PHP existants. Le fonctionnement des scripts PHP existants risque également d'être interrompu si vous passez au PHP-FPM en sélectionnant Gérer PHP avec Nginx dans les paramètres du serveur Web du site.

Version PHP

Plesk prend en charge plusieurs versions de PHP. Pour chaque gestionnaire, au moins une version de PHP est disponible. La liste des versions disponibles est définie par votre hébergeur. Vous pouvez la consulter là où vous sélectionnez le gestionnaire PHP : section Sites Web & Domaines > nom du domaine > Paramètres d'hébergement.

Remarque : utilisez toujours PHP 5.x sauf si vous avez besoin de PHP 4.x pour héberger certaines anciennes applications PHP.

Depuis Plesk 10.4, vous pouvez adapter la configuration PHP selon chaque pack d'hébergement ou abonnement. À cette fin, Plesk présente divers paramètres de configuration PHP sur l'onglet Paramètres PHP. Pour en savoir plus sur la personnalisation de la configuration PHP par abonnement, consultez la section Personnaliser la configuration PHP.

 

Leave your feedback on this topic here

If you have questions or need support, please visit the Plesk forum or contact your hosting provider.
The comments below are for feedback on the documentation only. No timely answers or help will be provided.