Risoluzione dei problemi relativi alle installazioni di applicazioni

Quando un'app non può essere installata nel sito web di un cliente per qualche motivo, i clienti ricevono un messaggio di errore che consiglia di contattare il proprio provider di hosting (tu). Il messaggio di errore contiene anche una breve descrizione che dovrebbe facilitare la risoluzione del problema.

Il problema più comune che si può verificare durante l'installazione di un'applicazione è quando PHP non soddisfa i requisiti dell'app:

  • La versione PHP non è supportata.
    Per risolvere il problema, installa la versione PHP richiesta. Per maggiori informazioni, consulta Installazione di PHP.
  • L'estensione PHP richiesta è disattivata.
    Per risolvere il problema, attiva l'estensione richiesta:
    • Per attivare l'estensione globalmente per una versione PHP specifica, accedi a Strumenti e impostazioni > Impostazioni PHP e fai clic sul nome di una combinazione qualsiasi della versione PHP e del tipo di gestore che utilizza la versione PHP desiderata. Puoi selezionare nella lista l'estensione richiesta oppure accedere alla scheda php.ini e aggiungere la direttiva PHP corrispondente al file php.ini a livello del server.
    • Per attivare l'estensione per un dominio specifico, aggiungere una direttiva PHP alla configurazione PHP del dominio. Per maggiori informazioni, consulta la sezione Impostazioni PHP.

Una volta aggiunta la direttiva, riavvia il server web. Pe maggiori informazioni, consulta Servizi di sistema.

 

Leave your feedback on this topic here

If you have questions or need support, please visit the Plesk forum or contact your hosting provider.
The comments below are for feedback on the documentation only. No timely answers or help will be provided.