Типы обработчиков PHP

Plesk предоставляет полную поддержку языка PHP, включая готовую поддержку множества версий PHP и типов обработчиков. В этом разделе перечислены типы обработчиков PHP, которые могут использоваться в Plesk.

Тип обработчика Производительность Использование памяти Подробнее об обработчике

Модуль Apache

Высокая

Низкая

Этот обработчик доступен только в Plesk для Linux. Это наименее безопасная опция, поскольку все скрипты PHP выполняются от лица пользователя apache. Это означает, что все файлы, создаваемые скриптами PHP любого подписчика, имеют одного и того же владельца (apache) и одинаковый набор прав. Таким образом, любой пользователь может повредить файлы другого пользователя или важные системные файлы. Вы можете избежать некоторых проблем с безопасностью, включив безопасный режим PHP (safe_mode). Безопасный режим отключает ряд функций PHP, создающих потенциальную угрозу безопасности. В результате этого могут перестать работать некоторые приложения. Опция safe_mode считается устаревшей и была удалена начиная с PHP 5.4.

Расширение ISAPI

Высокая

Низкая

Этот обработчик доступен только в Plesk для Windows. Если для подписок включен выделенный пул приложений IIS, расширение ISAPI позволяет обеспечить изоляцию сайтов. Изоляция сайтов означает, что сайты разных клиентов запускают свои скрипты независимо друг от друга. Благодаря этому ошибка в одном из скриптов PHP никак не скажется на работе других скриптов. Кроме того, скрипты РНР запускаются от лица системного пользователя, привязанного к учетной записи хостинга. Обработчик на основе расширения ISAPI не поддерживается начиная с PHP 5.3.

Приложение CGI

Низкая

Низкая

Обработчик CGI обеспечивает выполнение скриптов PHP от лица системного пользователя, привязанного к учетной записи хостинга. В Linux такое поведение возможно, только когда на сервере Apache включен модуль suEXEC (включен по умолчанию). В остальных случаях все скрипты PHP выполняются от лица пользователя apache. По умолчанию обработчик CGI недоступен клиентам Plesk.

Приложение FastCGI

Высокая

Высокая

Обработчик FastCGI запускает скрипты РНР от лица системного пользователя, привязанного к учетной записи хостинга.

Приложение PHP-FPM

Высокая

Низкая

Этот обработчик доступен только в Plesk для Linux. PHP-FPM - это расширенная версия FastCGI, которая заметно оптимизирует работу веб-приложений с высокой нагрузкой.

 

Leave your feedback on this topic here

If you have questions or need support, please visit the Plesk forum or contact your hosting provider.
The comments below are for feedback on the documentation only. No timely answers or help will be provided.