当无法在客户网站上安装某个应用程序时,该客户会收到建议其联系主机提供商(您)的错误信息。该错误信息还包括能够帮助您找出错误原因的简要错误描述。

在安装应用程序过程中最常见的问题是 PHP 不符合应用程序要求:

  • 不支持 PHP 版本 。 若要解决该问题,请安装所需的PHP版本。详情请参阅 安装PHP
  • 所需的PHP 扩展已被禁用 。 若要解决该问题,请启用所需的扩展:
    • 若要全局启用某个PHP版本的扩展,请进入 工具与设置 > PHP 设置 点击所需PHP版本的任一PHP版本 + 处理程序类型的组合名称。您可以从列表中选择所需的扩展,或进入 php.ini 标签添加相应的PHP指令到服务器范围的 php.ini 文件。
    • 若要为某个域名启用扩展,请添加PHP指令到该域名的PHP配置。可在章节 PHP 设置 中了解如何操作。

添加指令后,请重启web服务器。详情请参阅 系统服务