應用百寶箱執行本地庫和應用管理工具的功能。其本地庫的功能可以實現應用包的添加、更新和移除。使用其管理功能,您可以查看在 Plesk 中安裝了哪些應用,可以配置應用,或將其設定不能進行安裝。另外,您還可以通過清除百寶箱緩存來刪除臨時安裝檔。接下來,將詳細闡述如何執行這些操作。

需從伺服器管理面板中進入應用百寶箱: 伺服器管理 > 工具與設定 > 應用百寶箱

image-Installed-apps

添加您的應用程式到 Plesk

如果您有一個目錄應用程式之外的 web 應用程式想提供給您的客戶,您需添加到應用程式庫。注意您只可上傳以 APS 格式打包的應用套裝程式。

若要上傳您的應用程式,可使用 工具與設定 > 應用程式庫 > 我的應用程式 > 添加應用程式 。您上傳應用程式後,將在所有客戶的客戶面板裡出現。

image-Adding-App-from-Catalog

配置應用程式的伺服器級別設定

在這種情況下,客戶安裝目錄裡的應用程式之前需要對其進行伺服器級別配置。例如,如果一個應用程式的安裝影響了一些 Plesk 服務,可能需要管理員密碼。當您的客戶嘗試安裝此類應用程式時,他們會被要求聯繫他們的服務商(您)來執行此配置。配置設定後,客戶就可在他們的網站上安裝該應用程式。

應用程式的伺服器級別配置通常可適用所有應用程式安裝而且無法被客戶更改。例如,客戶無法安裝 ePages 電子商務應用程式,除非您定義了客戶應該如何存取應用程式,通過 HTTP 還是 HTTPS.

若要配置伺服器級別設定,需完成下面兩步:

  1. 若要添加目錄應用程式,可使用 工具與設定 > 應用程式庫 > 我的應用程式 > 添加應用程式
  2. 我的應用程式 裡的清單選擇應用程式並提交該設定。

管理應用程式對客戶的可用性

APS 套裝軟體上傳到百寶箱後,您就可管理其對客戶的可用性。如果您希望對 所有 客戶暫時隱藏您的應用程式,此選項非常有幫助。這樣可以在 工具與設定 > 應用百寶箱 > 我的應用程式 標籤裡設定該應用程式不可用。該應用程式將在所有客戶可用的應用程式清單中消失。若要使之返回該列表,可在 我的應用程式 標籤裡設定可用。注意您無法在您從目錄上下載的應用程式上執行這些操作。

image-App-Make-Unavailable

移除應用程式套裝軟體

只能 移除百寶箱中的套裝程式。您可從 工具與設定 > 應用百寶箱 > 我的應用程式 標籤移除一個應用程式,此百寶箱將刪除該應用套裝程式。

此操作並不影響 應用程式安裝 。已安裝的應用程式只能被特定的客戶從客戶面板裡移除(安裝者)。

跟蹤應用程式安裝

客戶一般通過本地庫安裝直接取自應用程式目錄的應用程式。唯一例外是您添加到百寶箱的應用程式。但是, 所有 應用程式的安裝都需在百寶箱裡註冊。您可通過 工具與設定 > 應用百寶箱 > 已安裝的應用程式 標籤查看安裝的詳情。清單裡應用程式零安裝表示應用程式套裝軟體存儲於百寶箱裡但任何客戶都不進行安裝。

上傳已安裝的應用程式

應用程式庫允許更新任何安裝於 Plesk 裡的應用程式到最新版本。在 Plesk 裡更新應用程式主要有兩個方案:某個應用程式安裝可被您或您的客戶(安裝者)更新。您可以進入 工具與設定 > 應用程式庫 > 已安裝的應用程式 標籤中檢查應用程式更新。如果更新已可用,您則可以點按 有可用的更新 。若要瞭解客戶如何能夠更新其應用程式,請參閱小節 更新應用程式

強制更新應用程式

您可以強制自動更新在 Plesk 中安裝的所有應用程式。那麼,Plesk 將會在有可用更新時自動更新所有應用程式實例。

image-App-Update-Settings

若要打開強制自動更新:

  1. 請轉入 工具與設定 > 應用程式庫 > 已安裝的應用程式 > 更新設定 頁面。
  2. 選擇選項 強制更新所有已安裝的應用程式

我們建議您只有在確定不影響網站功能的情況下才選擇該選項。這樣的情況可能會發生,例如當您的客戶使用應用程式擴展時:為某個應用程式版本開發的擴展可能會與更低的版本不相容。

Note: 如果您強制更新應用程式,您的客戶將無法關閉自動更新,請參閱小節 更新應用程式

清除應用程式百寶箱緩存

客戶安裝來自應用程式目錄裡的應用程式後,該應用套裝程式將存儲於伺服器上的一個臨時目錄裡,百寶箱緩存。緩存裡的檔可加速應用程式的安裝,但是您可刪除這些檔以騰出您伺服器上的磁碟空間。

如要從應用程式百寶箱緩存裡刪除暫存檔案,可轉入 工具與設定 > 應用百寶箱 > 已安裝的應用程式 標籤 > 清除緩存

App 安裝故障排除

當由於某種原因無法在客戶的網站上安裝 app 時,客戶會收到一條錯誤消息,建議與其主機提供商(您)聯繫。錯誤資訊還包含一個簡短的錯誤描述,可以幫助您找到問題的原因。

在 app 安裝過程中最常見的問題是 PHP 不滿足 app 要求:

  • PHP 版本不支援 。 要解決該問題,請安裝所需的 PHP 版本。詳情請參閱 安裝 PHP
  • 所需的 PHP 版本被禁用 。 要解決該問題,請啟用所需的擴展。
    • 若要為某個 PHP 版本全域啟用擴展,請轉入 工具與設定 > PHP 設定 點按任何使用所需 PHP 版本的 PHP 版本 + handler 類型組合的名稱。您可以從列表中選擇所需的擴展,或轉入 php.ini 標籤添加相應的 PHP 指令到伺服器範圍的 php.ini 文件。
    • 若要為某個域名啟用擴展,請將 PHP 指令添加到域名的 PHP 配置。轉到 PHP 設定 小節瞭解如何進行操作。

添加指令後,請重啟 web 伺服器。詳情請參閱 系統服務