升級 會對 Plesk 進行重大改進和提升並引進新的 Plesk 功能和操作。升級後,Plesk 會增加其大或小版本號:

  • 一般來說,如果升級只提升現有功能,Plesk 只會增加其小版本號(例如從 10.3.0 到 10.3.1)。
  • 如果升級包括對 Plesk 更為複雜的更改,其大版本號則會增加(例如從 10.3.1 到 10.4.0)。

Plesk 升級和版本層級

在 Plesk 整個生命週期中,每個大版本都會經歷一定的開發階段(查看下表)。在早期階段中的一些新增功能可能不會出現在最終階段的版本中,因為會進行進一步修改。在 Plesk 隨後的版本中此類特性功能會得以提升,因為會得到更多客戶的回饋。為了指明 Plesk 當前版本所處的階段,我們使用以下各個版本層級: 測試版本早期採用者版本通用版本後期採用者版本

Note: 1.測試版本預設不顯示為可安裝的版本。您可僅通過一個專門的選項運行 Plesk 安裝程式來安裝 Plesk 測試版本。請參閱 部署指南 中的 安裝 Plesk 章節中瞭解更多。

2. 只有測試版本的所有者才能將當期的測試版本升級到下一個測試版本。Plesk 後續小版本的 GUI 中沒有相應的選項。

決定使用什麼版本當然絕對取決於您自己。例如,如果您想要在 Plesk 發行通用版本前嘗試新增功能則可以考慮升級到早期採用者版本。如果您希望使用已進行所有主要更新且經眾多主機提供商成功試用驗證過的版本,則可以等候 Plesk 進入後期採用者版本階段時再使用(通用版本發行後兩個月左右)。

您決定使用哪個版本後,請設定 Plesk 在所選版本可用時通知您。您在 工具與設定 > 更新與升級 設定 中選定了版本類型後,Plesk 將會每日一次檢查升級。當選定版本版本層級可以升級時,Plesk 將會在 首頁 > 系統概要 上通知您。注意 Plesk 總是會在帶有“更高”版本層級的版本可用時給您通知。例如,如果您設定 Plesk 通知您有關早期採用者版本的資訊,您將會收到有關通用版本和後期採用者版本的所有升級通知。但是,如果您決定僅使用後期採用者版本,有關早期採用者和通用版本升級的通知將會被跳過。

下表顯示了 Plesk 大致生命週期情況(版本號僅作示範使用,不與真實版本號關聯)。

image-70050.png

應用 Plesk 升級

升級包含對產品的眾多更改,可能會造成較長的宕機時間,因而 Plesk 不會自動應用升級。而是會在 首頁 顯示升級通知。您收到此類通知後,可以在任何適合的時間從 首頁 > 系統概要工具與設定 > 更新與升級 啟動升級。

以上描述的方案是產品內升級,也就是在一台伺服器內更新 Plesk 組件。但是,還有一種方式可以升級 Plesk - 通過傳輸升級 。該方式是傳輸 Plesk 資料到其它安裝有更新版本的 Plesk 的伺服器上。例如當您不只要升級 Plesk 而且要將其移動到更高效的伺服器或其它的作業系統時,通過傳輸來升級是最適合的。若要瞭解不同升級方式之間的不同點以及升級 Plesk 的說明,請參閱 不是指南

Plesk 升級和許可金鑰

注意某些 Plesk 許可證不允許執行複雜的升級(更改大版本號的升級:例如從 10.3.1 升級到 10.4.0)。如果您嘗試執行此類升級,Plesk 將會警告您有關許可證局限性的資訊。然而,您仍將可以執行升級。完成時,您將需要為新的 Plesk 版本獲取許可證金鑰並進行安裝。欲瞭解升級後安裝許可證金鑰的資訊,請參閱 升級許可證金鑰

有關就地升級流程的說明

  • 升級到新的 Plesk 版本後,您將會收到有關升級流程的報告。如果升級成功,該通知資訊將包括事件日誌和已安裝的套裝程式列表。但是,如果郵件伺服器出現故障,則可能收不到任何錯誤通知。這樣您可以在 autoinstaller3.log 檔(位於伺服器硬碟上的 /tmp 目錄)中查看錯誤。
  • 在安裝影響 Plesk 核心功能的 基礎 套裝程式的過程中所有 Plesk 操作都會被暫停。
  • 自 10.3 版本起,Plesk 會允許直接從 更新與升級 頁面安裝備選的元件版本(例如 PHP 5.3、MySQL 5.5)。