Instalación de PHP

Plesk proporciona soporte para múltiples versiones de PHP y tipos de controlador. En este tema, el administrador de Plesk encontrará indicaciones para instalar PHP en el servidor.

Instalación y desinstalación de PHP

Para instalar una versión específica de PHP en el servidor o eliminar una versión del servidor, haga lo siguiente:

  1. Vaya a Herramientas y configuración > Actualizaciones y haga clic en la pestaña Adición/eliminación de componentes.
    • (Plesk para Linux) Amplíe la sección Hosting web y la sección Versiones del intérprete de PHP.
    • (Plesk para Windows) Amplíe la sección Prestaciones de hosting de Plesk.
  2. Aquí, las versiones instaladas de PHP se marcan con un icono de selección verdes, mientras que las no instaladas se marcan con un icono en forma de cruz roja. Seleccione las versiones de PHP que desea instalar haciendo clic en el icono correspondiente > Instalar. Seleccione las versiones de PHP que desea eliminar haciendo clic en el icono correspondiente > Eliminar. En la imagen que puede ver a continuación, se ha marcado PHP 7.1 para ser instalado y PHP 5.6 para ser eliminado.

  3. Haga clic en Continuar para instalar o eliminar las versiones de PHP seleccionadas.

Cuando se instala una versión de PHP, Plesk configura automáticamente los tipos de controlador de PHP estándar (CGI, FastCGI, PHP-FPM) para la versión.

Nota: En el caso de SOs anteriores, como por ejemplo CentOS 6.x, es imprescindible instalar el componente Soporte PHP-FPM del proveedor del SO para así poder usar el controlador de PHP-FPM. Encontrará este componente en la pestaña Adición/eliminación de componentes, concretamente en la sección Hosting web > Servidor web nginx y servidor de proxy inverso.

Puede hacer que determinados tipos de controlador estén disponibles o no disponibles para sus clientes para cada versión de PHP instalada en el servidor. Por ejemplo, puede permitir a sus clientes usar tanto FastCGI como PHP-FPM con PHP 7.1, pero únicamente PHP-FPM con PHP 5.6). Asimismo, también puede establecer una configuración de PHP distinta para cada versión de PHP.

 

Leave your feedback on this topic here

If you have questions or need support, please visit the Plesk forum or contact your hosting provider.
The comments below are for feedback on the documentation only. No timely answers or help will be provided.