啟用Node.js 支援

如要在伺服器上啟用Node.js 支援,請如下操作:

Plesk for Linux

  1. 進入 工具與設定> 更新與升級
  2. 進入 添加/移除組件 ,展開 主機 ,標記要安裝的 「NodeJS 支援」 組件。
  3. 點按 繼續 以開始安裝。

Plesk for Windows

  1. 進入 工具與設定> 更新與升級
  2. 進入 添加/移除組件 ,展開 主機 ,標記要安裝的 「Node.js IIS 模組 (iisnode)」 和 「Node.js」 組件。
  3. 在」Node.js」 組件下選擇所需的 Node.js 版本。
  4. 點按 繼續 以開始安裝。

備註: To use Ruby applications inside CageFS, install the passenger-cagefs package and follow the instructions in its README file.

管理 Node.js 版本

Plesk 支援Node.js 最新穩定版和 LTS版,但有以下局限性:

  • (Plesk for Linux) 可同時安裝兩個版本,不同域名上的 Node.js 應用可使用任何可用的 Node.js 版本。
  • (Plesk for Windows) 目前只能安裝一個 Node.js 版本,用於支援伺服器上所有的 Node.js 應用。

若要管理伺服器上可用的 Node.js 版本,請執行以下操作:

Plesk for Linux

  1. 進入 擴展 點按 Node.js Manager 。您可在此處查看在伺服器上安裝的 Node.js 版本以及相應二進位檔案的路徑。
  2. 點按 Node.js 某個版本旁的 image-76663.png 圖示可禁用該版本。禁用某個Node.js 版本有以下影響:
    • 當管理域名的 Node.js 應用時則無法再選擇被禁用的 Node.js 版本。
    • 現有的 Node.js 應用會被切換到其它啟用的Node.js 版本(如果可能)。
    • 如果伺服器上所有的 Node.js 版本都已被禁用,則會導致所有現存 Node.js 應用停止運行,也會移除對域名的 Node.js 應用的管理功能,直到至少重新啟用了一個Node.js 版本。
  3. 點按被禁的 Node.js 版本旁的 image-76664.png 圖示可啟用該版本。

Plesk for Windows

  1. 進入 擴展 點按 Node.js Manager 。您可在此處查看在伺服器上安裝的 Node.js 版本以及相應二進位檔案的路徑。
  2. 點按已安裝的某個 Node.js 版本旁的 image-76665.png 圖示可禁用該版本。這將會導致所有現存的Node.js 應用停止運行,也會移除對域名的 Node.js 應用的管理功能,直到重新啟用Node.js。
  3. 點按已安裝的某個 Node.js 版本旁的 image-76666.png 圖示可啟用該版本。
  4. 如要更改已安裝的Node.js 版本,請進入 工具與設定 ,點按 更新與升級 ,轉入 添加/移除元件 ,展開 主機 ,選擇 Node.js 組件下所需的」Node.js」 版本然後點按 繼續

控制 Node.js 是否開放給客戶使用

啟用 Node.js 支援會給服務方案和訂閱添加以下許可權,您可以使用常規的客戶許可權存取 Node.js 功能:

  • 「Node.js support management」 允許客戶為其域名啟用Node.js 支援。
  • 「Node.js state management」 允許客戶為其應用更改應用模式。
  • 「Node.js version management」 允許客戶為其應用更改 Node.js 版本。

為網站管理 Node.js 應用

欲瞭解有關為網站管理Node.js 應用的資訊,請閱讀 Node.js 支援 部分。