De eerste stappen na de upgrade naar Onyx

Dit hoofdstuk is bedoeld voor afnemers van hostingdiensten die eerder Plesk versie 9 of een eerdere versie hebben gebruikt. Hier worden de belangrijkste wijzigingen in Plesk beschreven en de verschillende problemen die zich kunnen voordoen nadat accounts en sites zijn verplaatst naar Plesk Onyx tijdens de Plesk upgrade.

De belangrijkste concepten die u moet kennen
  • Domeinen zijn vervangen door abonnementen.

    Het concept van domeinen is vervangen door het concept van abonnementen - hostingeenheden waarin meerdere websites (domeinen en subdomeinen) kunnen worden ondergebracht met een specifieke set van middelen en diensten. Ook als er meerdere domeinen worden gehost kan er binnen een abonnement maar één IP-adres worden gebruikt. Gebruikers die sites willen hosten op verschillende IP-adressen wordt aangeraden om aanvullende abonnementen aan te schaffen.

  • Middelen van een gebruiker zijn nu middelen van een abonnement.

    Customers no longer need to redistribute their resources across domains or subscription: Elk abonnement krijgt een vaste set middelen toegewezen op basis van een hostingpakket.

  • SSL/TLS-certificaten worden normaal gedeeld door alle domeinen binnen een abonnement.

    Alle sites binnen een abonnement delen normaal gesproken hetzelfde SSL/TLS-certificaat. Het is ook mogelijk om een certificaat per domein aan te houden als Plesk SNI ondersteunt.

    Om alle subdomeinen binnen een abonnement met één certificaat te beschermen valt de aanschaf van een wildcard SSL/TLS-certificaat te overwegen: deze kan voor meerdere domeinen worden gebruikt.

Bijzonderheden van de SiteBuilder-upgrade
  • Plesk Onyx wordt geleverd met Presence Builder (voorheen SiteBuilder), maar u kunt ook SiteBuilder 4.5 gebruiken.

    Presence Builder is een component van Plesk waarmee u snel en efficiënt websites kunt bouwen. Wanneer u een upgrade van Plesk met SiteBuilder uitvoert naar Plesk Onyx, dan zal de component SiteBuilder niet daadwerkelijk van een upgrade worden voorzien. In plaats daarvan wordt het nieuwe Presence Builder der op de server geïnstalleerd en blijft SiteBuilder 4.5 ook gewoon bruikbaar; echter, het enige dat u nog kunt doen met sites die in SiteBuilder 4.5 zijn gebouwd is bewerken en publiceren.

  • Het overzetten van websites van SiteBuilder 4.5 naar sb_name> wordt ondersteund, maar hierbij gelden beperkingen.

    Presence Builder maakt het mogelijk om sites uit SiteBuilder 4.5 te importeren. Deze mogelijkheid kent echter bepaalde beperkingen: sommige elementen kunnen ontbreken of beschadigd raken in de geïmporteerde website. Wij raden u aan deze met de originele versie te vergelijken en om eventuele ontbrekende content handmatig toe te voegen.

    Zie de sectie Sites importeren vanuit SiteBuilder 4.5 (op pagina ) voor meer details over het importeren van sites uit SiteBuilder 4.5 naar Presence Builder.

Wijzigingen in het opslaan van beveiligde informatie
  • httpdocs is de enige map waarin het opslaan van webbestanden is toegestaan waarvan de verspreiding beveiligd moet worden met SSL/TLS.

    Het is niet langer mogelijk om webbestanden die via SSL/TLS verspreid moeten worden op te slaan in een aparte map. Alle bestanden voor het web worden nu in één map opgeslagen - httpdocs.

    De map httpsdocs blijft wellicht achter in uw abonnement na de upgrade naar Plesk Onyx. Wij raden u echter aan dat u alle webbestanden plaatst in de map httpdocs wanneer u via FTP uw bestanden naar de server uploadt.

    Als u gebruik maakt van de optie om met SSL beveiligde bestanden en andere bestanden in aparte mappen op te slaan en u hebt met APS ingepakte toepassingen geïnstalleerd in de map httpsdocs van een website, dan zal Plesk na de upgrade voor deze site de compatibiliteitsmodus inschakelen. Daarmee worden de bestanden in de map httpsdocs toegankelijk vanaf het internet. Deze apps kunnen echter niet worden beheerd vanuit Plesk en u kunt ook geen nieuwe apps in de map httpsdocs installeren.

    In dat geval kunt u, wanneer u over de benodigde technische vaardigheden beschikt, het volgende doen:

    1. Maak een reservekopie van alle bestanden uit de map httpsdocs en sla deze elders op. Verplaats de bestanden nog niet naar httpdocs.
    2. Maak een reservekopie van de databases die worden gebruikt door toepassingen die zijn geïnstalleerd in de map httpsdocs. U kunt dit doen met het hulpprogramma mysqldump.
    3. Verwijderen toepassingen uit de map httpsdocs.
    4. Schakel de compatibiliteitsmodus uit via Plesk (op het tabblad Websites & domeinen > domeinnaam).
    5. Installeer de vereiste toepassingen opnieuw.
    6. Upload de gegevens waarvan u in stap 1 een reservekopie hebt gemaakt naar de map httpdocs.
    7. Herstel de databases van de toepassingen door deze in de MySQL-database-server te importeren.

    Als u niet zoveel ervaring hebt, dan raden wij u aan om de reeds geïnstalleerde toepassingen met de bijbehorende gegevens in de map httpsdocs te laten staan en om nieuwe toepassingen op andere websites te hosten. Als u apps moet installeren op een site in compatibiteitsmodus, dan kunt u deze installeren in de map httpdocs (http://) van de site.

 

Leave your feedback on this topic here

If you have questions or need support, please visit the Plesk forum or contact your hosting provider.
The comments below are for feedback on the documentation only. No timely answers or help will be provided.