Plesk предоставляет полную поддержку языка PHP, включая готовую поддержку множества версий PHP и типов обработчиков. В этом разделе мы расскажем о том, как администратор Plesk может давать клиентам доступ к различным типам обработчиков PHP и определять настройки для конкретных версий PHP.

Предоставление клиентам доступа к различным типам обработчиков PHP

Чтобы предоставить клиентам возможность использовать определенное сочетание версии и типа обработчика PHP, перейдите на страницу Инструменты и настройки > Настройки PHP. Вы увидите список всех имеющихся на сервере сочетаний версии и типа обработчика PHP:

image-75150.png

Значок image-75151.png рядом с сочетанием «версия + тип обработчика PHP» показывает, что это сочетание доступно вашим клиентам для использования, а значок image-75152.png показывает, что это сочетание недоступно. Нажмите на значок, чтобы переключить доступность конкретного сочетания «версия + тип обработчика PHP». Любой клиент, имеющий право выбирать версию и тип обработчика PHP для своих доменов, сможет выбрать любое сочетание «версия + тип обработчика PHP», которое вы сделали доступным. Справа от названия сочетания «версия + тип обработчика PHP» показывается количество доменов, которые его используют. Нажав на это число, вы можете просмотреть список доменов, которые используют это сочетание.

Типы обработчиков отличаются друг от друга уровнем безопасности и ресурсоемкостью. С помощью этой функции вы можете запретить клиентам использование определенного типа обработчика или определенной версии PHP (сделав недоступным все сочетания с этой версией PHP). Например, по умолчанию для всех версий PHP недоступен обработчик CGI PHP. Однако вы можете сделать его доступным для определенной версии PHP или для всех версий. Если вы сомневаетесь в выборе типа обработчика PHP, читайте о различных типах обработчиков PHP здесь.