Plesk 完全支援 PHP 指令碼語言,包括支援多個 PHP 版本和開盒即用的處理常式類型。本主題說明 Plesk 管理員如何設定 PHP 處理常式類型可供客戶使用,以及如何為各個 PHP 版本配置 PHP 設定。

設定處理常式類型可供客戶使用

若要使某個 PHP 版本加處理常式類型的組合可供或不可供客戶使用,需轉到 工具與設定 > PHP 設定 進行設定。您將會看到伺服器上所有可用的 PHP 版本加處理常式類型的組合的清單:

image-0

PHP 版本 + 處理常式類型組合旁的 image-1 圖示表示該組合可供客戶使用及選擇,而 image-2 圖示則表示組合不可用。點按圖示可切換一個 PHP 版本 + 處理常式類型組合的可用性。任何有許可權為其域名選擇 PHP 版本和處理常式類型的客戶都將可以選擇任何設定可用的 PHP 版本 + 處理常式類型組合。使用某個 PHP 版本 + 處理常式類型組合的域名數會在其名稱的右邊顯示,可以點按該數目查看使用此組合的域名清單。

不同的處理常式類型在它們的安全性和所消耗的資源上有所不同。您可以使用該功能禁止客戶使用某個處理常式類型或某個 PHP 版本(如設定使用某個 PHP 版本的所有 PHP 版本 + 處理常式類型組合都不可用)。例如,預設情況下,CGI PHP 處理常式不可用於所有 PHP 版本。但是,您可以將其設定可用於某個 PHP 版本或所有的 PHP 版本。如果您不確定要設定哪個 PHP 處理常式可用,請在 此處 閱讀有關不同 PHP 處理常式類型的資訊。