Vous pouvez exécuter des scripts PHP dans la ligne de commande pour une version particulière de PHP utilisée dans Plesk.

Sur Linux :

Dans Plesk pour Linux, le fichier binaire PHP (fichier php) se trouve sous :

/opt/plesk/php/<PHP version>/bin/php

<PHP version> doit être remplacée par le numéro de version PHP voulu.

Par exemple, si votre domaine utilise PHP version 7.0, utilisez la commande suivante pour exécuter le script my_script.php :

/opt/plesk/php/7.0/bin/php my_script.php

Sur Windows :

Dans Plesk pour Windows, utilisez les chemins suivants pour exécuter des scripts PHP :

%plesk_dir%Additional\PHP\php.exe - for PHP 4.x

%plesk_dir%Additional\PHP5\php.exe - for PHP version 5.2.x,

%plesk_dir%Additional\PHP53\php.exe - for PHP version 5.3.x,

%plesk_dir%Additional\PHP54\php.exe - for PHP version 5.4.x,

%plesk_dir%Additional\PHP55\php.exe - for PHP version 5.5.x,

%plesk_dir%Additional\PHP56\php.exe - for PHP version 5.6.x,

%plesk_dir%Additional\PHP70\php.exe - for PHP version 7.0.x.

Here, %plesk_dir% is the directory where Plesk is installed, usually, it is C:\Program Files (x86)\Plesk\.

Par exemple, si votre domaine utilise PHP version 7.0, utilisez la commande suivante pour exécuter le script my_script.php :

C:\Program Files (x86)\Plesk\Additional\PHP70\php.exe my_script.php